Editor autocomplete error on internal links with #

Steps to reproduce

  1. Copy this [[I am a internal link#chapter-name|TEXT_TO_SHOW]] to editor
  2. Delete and re-enter # or |

Expected result

[[I am a internal linkchapter-name|TEXT_TO_SHOW]]

Actual result

[[I am a internal link#chapter-name#]]chapter-name|TEXT_TO_SHOW]] for #.
[[I am a internal link#chapter-name|]]TEXT_TO_SHOW]] for |


  • Operating system: Mac OS 10.15.6
  • Obsidian version: 0.8.1

Additional information

1 Like

0.8.2 here, same behavior.

1 Like

I think this is the same issue I’m having.

@KatsumiYM I can’t see your gif. Nothing bad seems to happen in thie case.

Regarding, this bug. It looks fixed for | because we disabled the automatic autocomplete with | (you have to explicitly press tab before |)

out of curiosity, is there a reason autocomplete was disabled with | ?

will the little guide at the bottom of the autocomplete menu be updated somehow? if that change is going to stick and | and # are going to have different steps it would be misleading to keep it as is.

@KatsumiYM it fix another issue.

The little guide is still ok it says type | to change display text. It doesn’t say | to autocomplete.