Easier editing of checkboxes

What I’m trying to do

Is there any easy quick way to edit checkboxes? I don’t know if this is because of some setting I have, or some plugin, but I do believe this is how Obsidian generally works.

I don’t want my cursor to be forced and moved around when I go to edit a checkbox, specifically what’s inside the - [ ]. Every time I try to get into the brackets through keyboard, it gets pushed up a line or into the line, but not INSIDE the - [ ]. The only way to do so is by using your mouse to click into it, which I just don’t wanna do.

Is there a keyboard way of getting that, or is this just an obsidian thing that can’t be helped? If that is so, is there some plugin that could help achieve that (again, I don’t know if I’m stupid, but I’ve looked across forum for this and plugins too, please help!)

Thank you!

I cannot reproduce your problem.

In sandbox vault and live preview (Open sandbox vault):

  1. write - [ ], then space
  2. press left arrow key twice
  3. your cursor position: - [ <cursor>]

Source mode can be used as well, Toggle Live Preview/Source mode, or left click the icon in the status bar.

I didn’t know Sandbox mode existed, or thought of opening a new dummy vault to test if this an obsidian problem or not, so thank you for that!

And yup, you were right. I went to sandbox mode and tried it out and it worked out fine.

When I first realized this problem, I looked in the obsidian appearance settings, as well as the Tasks plugin I’ve got, and I didn’t find any setting to disable this, which is why I came to the forums.

Now after confirmation that it is something with some plugin of mine, I looked around more, and found the culprit. It’s a plugin called Outliner, and for some reason, it has an option to push cursor out of the - [ ].

Anyways, thank you for your help.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.