Drag & drop multiple files in the same folder - result in irreversible filename changes (2 bugs)

Steps to reproduce

  1. Select multiple files in navigation
  2. Drag and drop in the same folder

Did you follow the troubleshooting guide? YES

Did you really try the above steps in the sandbox vault (or a just any vault started in restricted mode, no snippets and default theme)? YES

Expected result


Actual result

All the selected files have their names changed with number 1 in end of their title. (ex. from “Note.md” to “Note 1.md”).

*This bug only occurs with dragging and dropping multiple files. If I drag & drop 1 file - it moves the file in a lower folder. This is the 2nd bug though.


Obsidian version: v1.5.3
Installer version: v1.4.16
Operating system: Darwin Kernel Version 23.2.0: Wed Nov 15 21:53:34 PST 2023; root:xnu-10002.61.3~2/RELEASE_ARM64_T8103 23.2.0
Login status: not logged in
Insider build toggle: off
Live preview: off
Base theme: adapt to system
Community theme: Minimal v7.4.3
Snippets enabled: 0
Restricted mode: off
Plugins installed: 3
Plugins enabled: 3
1: Style Settings v1.0.7
2: Advanced Tables v0.19.1
3: Global Search and Replace v0.3.0

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

I usually do this (drag & drop) to see how many Files are in the folder - I grab multiple files in navigation and I see a small text under the cursor “3 files” than I drop them in the same place. Therefore it’s not a serious bug, but still it’s a bug as the app should not behave this way. Accidental drag & drop of 30 files can result in additional work in renaming these files back, especially if I do not have the Sync feature to restore my vault to 5 minutes earlier.


Can you post a screen recording of this happening in the sandbox vault?


Here you can see both bugs:

  1. When I grab multiple files and place them in same folder - filenames change (with “…1” in the end)
  2. When I grab 1 file and place it in the same folder - it gets moved in a higher folder.

I archived the video as I cannot upload MP4 files.

Screen Recording 2023-12-27 at 4.48.41 pm.mp4.zip (1.8 MB)

Thank you. Now I understand

will be fixed 1.5.4


I have the exact same issue and when using a Wacom tablet (common tablet for graphic designers and illustrators), Obsidian registers a click as a click and drag? Maybe the tablet is lagging a millisecond, but I never had this issue in Obsidian before. What happens is that when I click on a note, 80% of the time it moves the note to the parent folder instead of opening. This makes using Obsidian with a tablet useless. Hope it’s fixed soon!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.