Drag drop attachments not working on Linux v0.8.12

Steps to reproduce

  • Create new note, edit mode and simply try drag & drop any media (tried jpg, png, webm etc).

Expected result

  • The attachment gets copied into the vault and linked/ displayed within the note.

Actual result

  • Silently fails


  • Obsidian version:

Additional information

Are you trying to drag and drop into the virtual machine that is running obsidian?

did this happen with older versions of obisidan?

@WhiteNoise: Yes, obsidian is running inside the VM. I have not tried it with older versions of obsidian, though I did try using a Nautilus file manager inside the Crostini Linux VM for ChromeOS, rather than the ChromeOS native file manager. But that didn’t seem to work either, which I though might work because both apps are inside the VM itself.

Also I can’t seem to drag and drop images into a note within the obsidian app after I manually move the file into the corresponding vault. Is that not a supported feature?

Since images are a huge part of my note taking workflow I am trying to figure out how I can get to a nice & streamlined setup given my environment.

Ok, so it’s probably doesn’t work because of your VM.

In your case, I suggest keeping an attachment folder in the vault for all the images and dump all your images in there. When you want to add an image to a note use the keyboard and autosuggestion ![[ name of img...

Yep, that’s my current workflow!

I ll try and dig into see how I can make drag & drop work with my Crostini VM and post here if I find something just in case anyone else is suffering from the same.

Just to confirm before closing this bugthough, is dragging & dropping within the Obsidian app not supported atm? As in my image is within the vault and shows up in the obsidian file explorer and I just want to drag it from there into a note.

yes, it’s not supported atm