Download for MacOS on M2 silicon not working from the main website

When I went to https://obsidian.md/ to download the program for Mac OS (I’m on M2 silicon) it downloads the program but each time it says the file is corrupt and I can’t install it.

That’s odd. What browser are you using to download? I assume Safari, but just want to check. You could try using Chrome, Firefox, etc., to download and see if there’s any difference.

If you go to this page: Releases · obsidianmd/obsidian-releases · GitHub and download the “Obsidian-1.5.3-universal.dmg” for macOS, does that work?

direct link → Obsidian-1.5.3-universal.dmg

Hey, thanks for trying to help troubleshoot. I downloaded it through Chrome and just tried through Mozilla but still no success. I had also tried the universal version and one that was supposed to be for the M2 chips as well.

I might just have to go back to Windows…

That is super strange. I have an M3 Max Macbook Pro and the download worked just fine.

Indeed it’s strange, I just tried it again but no luck. This is after having restarted the computer too just in case.

Try installing homebrew and installing it via the terminal.

If you aren’t sure how based on the link above I can guide you through it.

  1. Open Terminal

  2. Copy the code below and paste it into the terminal and press enter (this is how you run commands):
    /bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh)"

  3. that should install everything you need for homebrew.

  4. Run this command to make sure everything was installed correctly:
    brew help

If there are any errors, let me know. Copy and paste them here and I can help you from there.

As long as it installed correctly run this to install Obsidian via Homebrew:
brew install --cask obsidian
That should install it.

Is it possible that your ISP is corrupting the file transfer? Where in the world are you? Does it happen if you use a VPN?

Gentlemen & Gentleladies, I’ve got it working now! Not sure why it wasn’t working before but I just updated to Sonoma 14.2.1 and it finally works now!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.