Don't copy backticks when highlighting text in editor mode

Steps to reproduce


Expected result

Code to be copied without the trailing and leading “`”

In the gif above there wasn’t a trailing backtick, not sure how to reproduce this, but it happens sometimes. Though the missing backtick fact is completely irrelevant to this request. The point is that the backtick gets copied with the text, which is the undesired action.

Actual result

Code is copied WITH the trailing and leading “`”


  • Operating system: lin and win

Additional information

I understand this might not be a bug, since I technically am in the editor mode, but perhaps there should be an option whether to copy the backticks or not.

I’m guessing most of us spend time in the live preview editor mode without any need to go into reading mode, and constantly copying code from notes with backticks gets annoying real fast.

Also, this might be a solution to all our problems:

1 Like

This is a feature request not a bug report. Please search/open one in the right category.