Does not react on linux

I can’t interact with the program, any change I do will show up next time I start the program. This is both with the AppImage and the Flatpak version.

Steps to reproduce

  • Install by Flatpak or AppImage
  • Run the application
  • Try to do anything

Expected result

I should be able to type or click on things

Actual result

The program does not respond, everything I type or delete is changed next time I start the program and the result of clicking (e.g. opening an other note) is done the next time.


  • Operating system: OpenSuse Tumbleweed
  • Obsidian version: 0.11.0 but this issue has been present for several versions already and in lesser form (resizing makes the program freeze) since 8.0 9.20 or something, since I started using Obsidian.

Additional information

I have not tried the snap version.
The AppImage does not throw any errors to the terminal, this is everything (after having tried the --appimage-extract flag, it also doesn’t work before using it):
2021-02-19 08:40:10 Loading main app package /tmp/.mount_ObsidiDrrtlo/resources/obsidian.asar
Updates disabled.
xdg-settings: default-url-scheme-handler not implemented for xfce

Hi @Twijg, sorry to hear that’s happening. Could you let us know what is your installer version? Could you add more details to the “Run the application” steps, i.e. what is the size of your vault? which folder did you chose? does it happen to all vaults? does it happen with the help vault too? Do you have custom css on? are plugins activated?

The AppImage opened a small vault with ± 20 short text files in 3 folders.
The Flatpak was new installed and opened the help vault by default.
I haven’t used obsidian in a while now and can’t access the settings but looking at the .obsidian folder:
I use the Blue Topaz or the Amethyst theme with no css snipets and a few plugins: table-editor, citation, convert-url-to-iframe (I don’t use this one and don’t have iframes in my files), code block copy and editor-syntax-highlight

(I edited the original message, the freezing on resizing was there since I started using obsidian, which was probably version 9.20)

Please update your installer if you haven’t already (not sure which version you’re on). I can’t really reproduce this in Ubuntu 18.04. Can you use other electron-based apps without issues? Can you delete the cache in ~/.config/obsidian/ObsidianCache/?

I don’t know what you mean by updating the installer but I always did a fresh install of every new version of Obsidian. Removing the .config/obsidian helped but not a lot, I could type but any mouse interaction freezes it in the Help Vault, others vault still don’t work at all. Other electron apps work fine.
Thank you for helping me.

I meant downloading a new AppImage each time. You can see your installer version in Settings > About.

It took my quite a few tries (that’s why I gave up earlier) but I managed to get to settings > about without it freezing, the installer version is v011.0

What is the path of your vault?

post a screen recording, what is the size of your vault, what are your computer spec? have you tried running obsidian with --disable-gpu

1 Like

Running with --disable-gpu seems to make it work, thanks!

(To answer the questions, my vault is a folder under ~/Documents/, I use a normal Lenovo laptop with intel cpu + graphics and my vault is small)