Do not place cursor in file when open from Files

Use case or problem

When I open a file from the Files panel on Desktop, Obsidian automatically inserts the cursor at the beginning of the file triggering the Live editor to show the title hashtag symbol: “# Title”.

To fix this, I sometimes click on the same file in Files again to remove focus and the cursor.

Proposed solution

Do not place the cursor automatically if it wasn’t there before.

1 Like

You may want to change Settings > Editor > “Default view for new tabs” to “Reading view”. (and switch your currently open tabs to Reading view).