Display properties from YAML within note as a bullet list

As I found in this thread it is possible to display properties from YAML within the note, for example:

= this.Author

I have multiple authors in the Author YAML field and with the trick above they are displayed comma separated in the note.

My question: How to display the multiple authors as a bullet list?

I think what you are looking for is not possible with an inline query. As per Dataview documentation

I tried this but I get a Promise.

`$=dv.list(dv.current().author);`

What works though is a dataviewjs chunk, like so:

```dataviewjs
let page = dv.current();
dv.list(page.author);
```

It’s kind of strange that you got a Promise out of that call, as it shouldn’t return that. If however it was meant to return that, like various Templater functions, you could use await in front to resolve the promise.

But in general I’ve never needed to so for a inline query, so this should work as the minimal example to display such a list:

`$= dv.list(dv.current().Author) `

I tried await in all its imaginable variations.
Still doesn’t work.
I guess it is a limitation of inline JavaScript, if we follow the documentation. One line per response; no multiline.

It’s not a limitation of dataview itself. I’ve done this for ages. It’s rather a combination of some other factors. Like your installation, Obsidian version, plugins…

Which version are you currently on? Could this be related to 1.5.8 which I’m having large issues with currently? (Not this issue, but other stuff).

But there is no problem having dataview return multiple lines of response using inline queries. I daily build large group of objects both in my test vault and personal vault, so your issue is related to your setup somehow.

I am in 1.5.3

image

EDIT
Correction: 1.5.8

I relaunched and automatically upgraded to 1.5.8.

The problem presents in 1.5.3 and 1.5.8.

Tested in a clean, brand new vault, but 1.5.8

image

image

OK, to further pursue this issue you should post a new thread. It’s not correct of us to hijack this thread to discuss something which clearly isn’t related to the question this thread is supposed to be about.

1 Like

<Promise> on my dv.view one-liner (unrelated to this thread) as well (1.5.3).
If I await it, all I get is a - on that line as result.

1 Like