Display math in blockquote shakes while typing with IME on

Once you’ve done the above, delete everything above this line.

Steps to reproduce

  1. Open the sandbox vault and create a new note with the following content:
    > $$f(x)$$
  2. In Live preview, put the cursor after the > on the second line.
  3. Turn on a Japanese IME and type the following: a, i, Enter, u, e, and Enter (which will append あいうえ to the line).

Did you follow the troubleshooting guide? [Y/N]


Expected result

The rendered display math ($$f(x)$$) should not move while typing because we are not touching it.

Actual result

With each key press (while IME is active), the rendered equation shifts slightly left and right if the pressed key is Enter or it’s pressed right after Enter. See the attached video.

When typing with sufficient speed, this can be distracting.


Obsidian version: v1.5.12
Installer version: v1.5.12
Operating system: Darwin Kernel Version 22.6.0: Mon Feb 19 19:43:41 PST 2024; root:xnu-8796.141.3.704.6~1/RELEASE_ARM64_T8103 22.6.0
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

Screen Recording 2024-04-28 at 20.54.38