Disabling Auto pair Markdown syntax disables autopairing backticks

Steps to reproduce

  1. Open sanbox vault
  2. Go to Settings > Editor > Behavior > Disable “Auto pair Markdon syntax”
    Note the description: “Pair symbols for bold and italic.”
  3. Leave settings
  4. Go a note and type `
  5. type ` anther 2 times (3 in total)

Did you follow the troubleshooting guide? [Y/N] y

Expected result

Two backticks after step 4.
Three backticks after step 5 for a fenced block.

Actual result

Only one backtick after step 4.
Only three backticks after step 5.


	Obsidian version: v1.5.4
	Installer version: v1.5.3
	Operating system: #1 SMP PREEMPT_DYNAMIC Mon, 05 Feb 2024 22:07:49 +0000 6.7.4-arch1-1
	Login status: logged in
	Catalyst license: insider
	Insider build toggle: on
	Live preview: on
	Base theme: adapt to system
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on


Additional information

One could say the bug is only in the description or one could say the option should not disable backtick pairing. I belong to the latter group and I hope I can only turn off bold and italic auto pairing.

My suggestion would be to
a) make it integrate backtick toggle into “Auto pair brackets” option
b) make a separate toggle
c) have two lists of what to pair and what not to pair (that’s feature terretory now)
d) fix the description *booo*

(This relates to (Content) Update help text for "Auto pair Markdown syntax" setting but is not the same)

1 Like

The description is a non exhaustive list.

If it is not exhaustive I would suggest something like this:

Pair symbols automatically for bold, italic, highlight, backticks, and more.

(stolen from @dsteinbock’s (Content) Update help text for "Auto pair Markdown syntax" setting)

Feel free to open a FR for that.

I suggested multiple solutions. Three of them (a, b, c) can be considered features or at least changes to behavior. But the jokingly crossed out option d to fix the description is the fix to this bug.

I think the Principle of Least Surprise applies here. Disabling this option suprised me, which is clearly a bug — even if it is just description that is wrong.

To make another example: If you had a button that said “Delete files a and b” and it wiped your whole drive would you consider that a bug, if the button was meant to wipe the drive?

Faulty descriptions are bugs.

If there was a repo to commit to, I’d even open a PR/MR to fix it myself.

Which keyboard layout are you using?

It sounds like a non-english variant, so you might need to type ` plus space to get one bactick, and repeat that three times for three backticks.

Also see the note below:

Combining ` with e does not yield è.
It is not a dead key issue. One press of the backtick key gives me one backtick and if I turn on the “Auto pair Markdon syntax” option, it does auto pair the two backticks.

There is! The link is near the bottom of the Help homepage.

But that repo is for the help page, isn’t it? I wanted to change Obsidian itself and fix the description (or other).

I searched for the current description and couldn’t find it. It is definitely the wrong repo.

Oh! Yeah, sorry, I misunderstood.

1 Like