Disable Markdown, pt. 2

This is a follow-up to Disable markdown in which I selected a solution and was going to add the below comment on it, but it immediately closed when I clicked the solution button. Anyway,

I tried the plaintext community plugin, but it seemed like searching did not look inside those .txt notes, and also Ctrl-F within an open txt note didn’t work (no find dialog opened).

I think the css provided earlier has been the most effective so far. I did add some additional entries:

.markdown-source-view.mod-cm6 .obsidian-search-match-highlight {
    background-color: rgba(243,50,100,0.9) !important;
}

.markdown-source-view.mod-cm6 .cm-selection {
    background-color: rgba(110,130,130,0.7) !important;
}

The initial css (in the first forum post) also turned off highlighting of selected text and found text. My css game isn’t great, but the above worked for me for those 2 cases.

I also didn’t want my links click-able, so i added this bit:

.cm-url, .external-link {
    cursor: default;
    pointer-events: none;
    text-decoration: none !important;
}

now i just need to break the habit of using my old system.

Another snippet to eliminate italics in “source mode”

.markdown-source-view.mod-cm6 .cm-em {
    font-style: normal; !important
}