Disable line wrapping in edit mode

Is there a way to disable line wrapping when editing? I much prefer to put my line breaks manually in MD, because of compatibility with other editors and also because I use Vim keymappings and it makes navigation a lot easier.

I checked the settings, I only found a setting to ignore line breaks, it’s turned off. I did a quick search of the docs but didn’t find an obvious solution.

Sure, this will disable line wrapping for all content - in edit mode.

/* disable line wrap - edit mode */
.ͼq .cm-content {
    white-space: nowrap;


You can turn off Settings > Editor > “Readable line length”, but it will also affect Reading View.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.