Disable automatic link formating on external links

Hello,

I’m looking for a way to disable the autodetection of external links triggered by www.

When I type www.example.org, Obsidian turns it into a link. I can ‘escape’ it by prefixing it with a backslash \www.example.org, but the backslash then shows up in Excalidraw.

Links should be links only when I say they are links.

I couldn’t find a solution when searching the web, but I might not have used the correct keywords.

What’s worse that completely random Sumerian compounds (they are written as NUN.ME.DUG e.g.) are seen as clickable links on my published site. Yeah, a regex was needed to find these and the dots had to be escaped.

I think a http(s) (and their counterparts) should not be spared for a web URL.

( Yeah… I’m really having a problem with random Sumerian compounds appearing in my notes… :smiley: )

On a more serious note, at least regarding “domains” starting with a given prefix, i.e. www, I reckon those could be targetted with something like [href^="www"] and styled not to look like links. One could possibly add pointer-events: none to remove the click action, maybe.

Not sure how easy that would be to apply to those compounds, as I don’t know how many that would amount to.


A similar approach could possibly be done through remove styles from all links, and then reapplied to those starting with: http(s), obsidian, and so on (or potentially to those containing a colon, :).

Well, those are a few ideas related to styling them as non-links. And no, I’ve not heard of any options to disable these links at a lower level.