Different Dataview output in preview and reading mode


strange thing with Dataview :wink:

What I’m trying to do

I have a daily log in which I track, among other things, my tasks done during the day. The result is somewhat strange:

  • when I am going into reading mode I see the correct data, however,
  • when I am in preview mode, I see different data :flushed:

I am using a little callout and then have the Dataview code.
The code is as follows:

> [!blank]
> - #### Tasks done today #mcl/list-card 
>> ```dataview
>>TABLE  WITHOUT ID regexreplace(Tasks.text, "((([πŸ“…β³πŸ›«β«πŸ”ΌπŸ”½].*|\<.*)\n*$))", "") AS Task, file.link AS "File"
>>FROM "1 aws"
>>FLATTEN file.tasks AS Tasks
>>WHERE Tasks.completed AND substring(dateformat(Tasks.completion, "yyMMdd"),0) = substring(this.file.name,0,6)

The result looks depending on the reading or preview mode as follows - (I have put a gray box above the individual tasks, as I am using real data :wink:):

Things I have tried

Now comes the most peculiar thing:
when I make a little change to the code and change immediately back again and then render new … the correct data is shown.

I have tried this with different folders (and different numbers of tasks) and I always have a difference between both modes, and when I edit the Dataview and back, render new, the outcome is correct.

Any help what to do, would be fantastic.

Have all a wonderful Sunday!


I’m not fluent with dataview, but just to rule out potential effect of callout, does the same issue persist if you do it without the callout?

Thanks for the thought!

Yep, that was my first idea – same issue with or without callout :wink:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.