Did multiline YAML break in v0.14.6?

Things I have tried

I have searched this Forum and Obsidian Help docs, and I have found nothing to help resolve this.

What I’m trying to do

I am trying to use tags in multi-line format in YAML frontmatter.

Stack Overflow describes multiple ways to get multiline strings in YAML but suggests most of the time to use >, with subsequent interior line breaks stripped out. Screenshot shows a stubfile with this but where Obsidian 0.14.9 then says “Invalid YAML”. If I remove the line break and join the original lines 6-7, Obsidian reckons all is fine and stops complaining.

Screenshot 2022-04-30 182504

Screenshot 2022-04-30 182426

Obviously when the multi-line is just two, this isn’t a big deal. But I have many files where I’d used the multi-line convention, and my memory is that it had always been OK previously. (I jumped from Obsidian 0.13 to the current so the change I’m asking about might have occurred sometime earlier than 0.14.9.)

I have also tried the multi-line given in Working with tags but that’s not working really well for me, and in any case, it’d be good to clarify if that YAML format is or is not acceptable for Obsidian.

Thanks.

Hello.

Using…

---
fileName: test-multiline-yaml.md
# Last-edited:2022.84.30.1824.Satl-DannyQuah([email protected])
Type: Notes
Tags: >
  Software, Storage, Cloud, GoogleDrive, Sync-DQ-CLoud, Internet-Cloud,
  Box, Dropbox
# Created: 2022.04.38.1814.Sat - Danny Quah([email protected])

output: pdf_document
title: Test multiline YAML
---

I don’t get the invalid-YAML warning in v0.14.6 (installer also v0.14.6) on macOS. Is your installer up to date?

Angel

1 Like

Thanks, @Angel, for checking and responding. Glad to see it working on your end. Hmmm, yep, my Installer’s up to date.

1 Like

Problem solved. One of the two whitespace characters leading on the second line turned out, invisibly and inadvertently, to be “^I Hex 09” rather than what it should have been " Hex 20".

YAML rules. :innocent:

1 Like