Developer Tools in Mac Not Accessible

What I’m trying to do

Hi, I am trying to increase the width of a PDF embedded in a note and read on the forum that it can be done through accessible the developer tools. I tried it through the main menu (View) but its not selectable. I tried the keyboard shortcut (Alt-CMD-i) but this too doesnt do anything? Any advice or help?

p.s. I am using a Mac.

Things I have tried

3 things:

Can you paste your “Show Debug Info” command results?

And possibly show a screenshot of your menu, where it’s not selectable.

Where did you download Obsidian from? Recently it was discovered there was a fake site distributing a malware version. Make sure you installed from the official site.

Hi, thanks for the reply.

How do I access the “Show Debug Info”?

Here’s a screenshot

Help > Show Debug Info

The text can be copied from the debug window and pasted here for diagnostics.

Stupid question, but do you have a window open (with some random file) when you’re trying to open Developer Tools?

Here it is:

Obsidian version: v1.1.16
Installer version: v0.15.9
Operating system: Darwin Kernel Version 21.3.0: Wed Jan 5 21:37:58 PST 2022; root:xnu-8019.80.24~20/RELEASE_ARM64_T6000 21.3.0
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: light
Community theme: Sanctum v1.1.9
Snippets enabled: 0
Restricted mode: off
Plugins installed: 12
Plugins enabled: 12
1: Citations v0.4.5
2: RTL Support v1.0.0
3: cMenu v1.1.2
4: Highlightr v1.2.2
5: Short Internal Links to Headings v1.0.2
6: Expand Bullet v1.0.2
7: File Tree Alternative Plugin v2.2.8
8: Ordered List Style v0.1.0
9: File Color v1.0.2
10: Minimal Theme Settings v6.2.0
11: Style Settings v1.0.0
12: Footnote Shortcut v0.0.9

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

In Obsidian I only have the main window open.
I have other apps open too.
Is that what you meant?

Yeah, you need to have at least the main window with some file open. I didn’t see it at first in your screenshot, but when looking a little bit closer I saw it on the far right.

Are you able to open the Developer Tools in the sandbox vault?

I’ve experienced it not showing a few times, at one point I felt it was related to splitting up the main window into multiple tab groups, but then again, that wasn’t always the case. So it works for me (on Mac) almost always. But if you’re using multiple tab groups, that could also be worth testing to see if it then helps to close down to just one tab group.

1 Like

This worked! Thanks so much!

You should also download and reinstall Obsidian from the website. Your v0.15.9 installer is very out of date. You’ll be missing some of the latest components that can’t auto-update inside the app.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.