Deleting text deletes file?

Things I have tried: Disabled all plugins

What I’m trying to do: Just normal editing, but randomly, when I want to delete text, a different file that is showing is deleted.

I have put the setting to warn me about deleting, so I’m not pulling out my hair, but why is this happening?

Are you using any kind of sync (Dropbox, iCloud, etc)?

1 Like

I agree it’s likely a syncing tool. Where are you storing your vault?

But in general please share more info. Can you paste the results of “Show debug info”?

Or if it is warning you about deleting, maybe you are accidentally triggering a hotkey/command. I’d also search through your hotkeys and make sure you didn’t accidentally map a common keystroke to a delete command. Or think about any hotkey/snippet apps you have installed on your computer.

1 Like

I am not syncing, and the only key I’m using is delete. This is why I really didn’t have more information to share. It will attempt to delete some other file that is showing, (and now that I have changed the settings to warn me) on the second attempt, it all works correctly, that is, the text is deleted.

I will attempt to paste the results of the show debug info next time it happens.

Please paste “Show debug info” now. It shows the configuration of your vault. It’s not an error log.

Ah, I see. Thanks for the help. Here is the debug info:

Obsidian version: v0.16.2
Installer version: v0.15.8
Operating system: Windows 10 Home 10.0.19044
Login status: logged in
Catalyst license: vip
Insider build toggle: on
Live preview: off
Legacy editor: off
Base theme: dark
Community theme: publish
Snippets enabled: 2
Restricted mode: off
Plugins installed: 40
Plugins enabled: 7
1: Automatically reveal active file v1.0.2
2: Collapse All v1.5.3
3: Paste URL into selection v1.7.0
4: Advanced Tables v0.17.3
5: Recent Files v1.3.3
6: Table of Contents v0.1.3
7: Natural Language Dates v0.6.1

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

What does the plugin “Automatically reveal active file” do? Sounds like something that manages the automatic highlighting/focus of a file. That sounds super suspicious given the description of the issue.

You should try disabling that one first, to test if it causing the trouble. And then if it still happens, try disabling all community plugins to test if that is the trouble. And don’t forget to restart when disabling, just to make sure it unloads completely.

If you can isolate that it is something other than a plugin, then we can keep digging for clues. But that’s your first test.

And basically yeah, follow the advice in the “RECOMMENDATIONS” section of that debug info.

Thanks very much. I will do just what you say and report back (in a few days).
I guess I was checking if this was a common and known thing. Your troubleshooting steps are clear, and I’ll share what happened.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.