Deleted Files Permanent?

My vault is a Dropbox folder (Mac Sonoma 14.0)
When I delete a file in Obsidian, it does NOT go to the trash can - just gone
When I delete the same file from Finder, it DOES go to the trash can.

Is this behavior new?

I THINK in the past files deleted in Obsidian went to the trash can

Hi @Mathias, you can configure this behavior in Options > Files & Links:

That is what I have it set to
But it still permanently deletes
Noticed it after upgrading to Mac Sonoma 14.0

Also tested with the confirmation message on which says it will be moved to the trash

But it is still permanently deleted.

Although I’ve read it worked for you deleting files from Finder, maybe it’s something about Trash in Sonoma 14.0…

I’ve found this:


I can move things to the trash fine.
It’s just Obsidian that I have noticed so far that permanently deletes instead of moves.

I tested on Sonoma and my file went to the trash — but my vault isn’t in Dropbox.

Made a test vault in Dropbox and the file I deleted from there went to trash, too. Dropbox popped up a window saying the file would be removed from Dropbox.

Here is a video of it happening

And my settings

I seem to remember this coming up a few times pre-Sonoma, so it may be a Dropbox update or setting and unrelated to Obsidian.

Also, respect to all you brave souls updating macOS right away. :person_fencing:

It has been the same vault I have always used
If I delete a file there using Finder, it then shows in the trash bin

Are you on the latest Installer version? You can see your App and Installer version on the “About” page in settings.

Just thought I’d ask, sometimes it’s the easiest solution.

Screenshot 2023-10-01 at 17.57.26

When I tested in Dropbox before, I deleted from the 3-dot note menu and didn’t put any text in the body. I tried again with text in the body and deleted from the sidebar context menu but it still went to the trash. Mystifying!

I am doing this in my personal Dropbox, but I also have a work Dropbox on the same machine (I would t expect that to matter, but it’s a possible difference).

The settings for my personal Dropbox, in the Sync tab, at the bottom, say I’m “not eligible for the updated Dropbox for MacOS on File Provider at this time.” Maybe you’re on the updated one and it behaves differently with Obsidian for some reason?

Thanks for checking
I’m not that worried about it now that I know what it is doing I will try to remember to be careful
I don’t delete that often from Obsidian (I think)

But others may run into this with the new Sonoma 14

As with many computer issues, it could be for hundreds of weird reasons.

I had this problem before Sonoma and I still have it. The same thing happened to me with iA Writer. Almost a year ago I spoke with the Dropbox developers (I was using a beta version) and in a new stable version it has been resolved with iA Writer but the same behavior continues with Obsdian. I will write again on the Dropbox forum…

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.