Delay in all functionality

What I’m trying to do

I am trying to basically just use obsidian normally. This includes opening files from the folders, moc, and graph view, installing or uninstalling plugins, updating the plugins and appearances. What happens is as follows:
Opening files: no matter from which source I open files, they take upwards of 15 or 20 minutes to open if they open at all - sometimes they time out entirely. When I open them in a new tab it has the title and no content - and the bar at the top says “no file”.
Installing plugins: it’ll take 10 minutes for the plugin to install and once I press the button it’ll become unresponsive. I can close settings but it renders my plugin search capabilities useless. When they finally install, I have the same issue enabling them. When I try to uninstall, occasionally the “uninstall” button will be completely unresponsive.
Updating plugins and appearances: same issue - it just freezes.

I would like to be able to use obsidian without it freezing on me. I just started using it so I don’t think I really have enough content on there for it to be a bulk issue.

I am on mac and am using version 1.4.16

Things I have tried

I tried to update all plugins and appearances (I think it worked, but the process timed out several times). I checked the sandbox vault and there wasn’t the same issue - no freezing issues and I checked/was able to install and uninstall a community plugin.

I downloaded divide and conquer to see if there were issues with any of the plugins but it glitched and when I tried to uninstall it, it deleted all of my plugins. (or at least that’s what settings says… my dataview tables and home page omnisearch is still working)

Here is my debug info:
Obsidian version: v1.4.16
Installer version: v1.4.16
Operating system: Darwin Kernel Version 23.0.0: Fri Sep 15 14:41:34 PDT 2023; root:xnu-10002.1.13~1/RELEASE_ARM64_T8103 23.0.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: adapt to system
Community theme: Light & Bright v2.0.0
Snippets enabled: 0
Restricted mode: off
Plugins installed: 0
Plugins enabled: 18
1: Calendar v1.5.10
2: Better Word Count v0.10.0
3: Checklist v2.2.13
4: Clear Unused Images v1.1.0
5: Copy Block Link v1.0.4
6: Convert url to preview (iframe) v0.5.0
7: Dataview v0.5.64
8: Dice Roller v10.4.0
9: Dictionary v2.22.0
10: Doubleshift v2.2.1
11: Find orphaned files and broken links v1.9.1
12: Homepage v3.6.0
13: Hover Editor v0.11.15
14: Iconize v2.8.0
15: Icons v0.3.0
16: Hotkeys for templates v1.4.3
17: Editing Toolbar v2.4.0
18: Home tab v1.1.2

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

I don’t know how to upload the issues log or if this is even the right place to post and ask for help. Let me know if I can provide any more info, and thanks everyone for reading!

You can manually remove plugins by moving their folders out of the plugins folder (which is in the hidden .obsidian folder in the vault) and restarting Obsidian. So to do what Divide and Conquer does, move half the plugins out and restart. If that doesn’t help, put them back and move the other half out. If that helps, put half back in, etc. until you find the culprit.

thank you! I did manage to manually figure out which plugin was giving me trouble.

It could be nice to know which plugin was the culprit, and what you did to resolve the issue. This could be helpful for someone in the future having a similar issue.

1 Like

I think it was the Home tab plugin because most of my issues went away when I uninstalled

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.