Deep linking on Android opens the app but not the note

Steps to reproduce

  • Create a link via “Copy Obsidian URL” (e.g. obsidian://open?vault=my_vault&file=Now)
  • Attempt to open the link on Android

Expected result

  • The Now note should open

Actual result

  • The app re-opens but does not change the focused note


(same behavior in restricted mode, though macOS and iOS work as expected)

Operating system: android 13 (Google Pixel 6)
Obsidian version: 1.4.4 (99)
API version: v1.2.7
Login status: logged in
Catalyst license: supporter
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 15
Plugins enabled: 6
1: Google Photos v1.1.12
2: Periodic Notes v0.0.17
3: Templater v1.16.0
4: Quiet Outline v0.3.15
5: Outliner v4.1.0
6: Audio Player v0.1.1

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

I specifically see “Loading your vault data” when clicking the link.

Reddit - Dive into anything may be the same issue (if that helps time things)

As an addendum…

The Reddit link talks about Todoist and I tried to do it directly from Obsidian. I was testing for Tasker, however within Tasker I used my regular URL even though I was just going to open the app with it for now, and it worked :person_shrugging: I still think this is a bug, but for whatever reason Tasker’s “Browse URL” worked.

This is still a general bug that I would like to see resolved (non-urgently) and my Tasker stuff still works.

I thought this was fixed in recent versions of obsidian. Can you post a screen recording?