Date formats changed with 1.4.5 upgrade

What I’m trying to do

I had my dates all set to the format YYYY-MM-DD, but now after the update to 1.4.5 they have reformatted to DD-MM-YYYY

Things I have tried

I’ve looked through all the possible places to set the format in plugins etc, and changed the Ubuntu formats locale to Canada (which is YYY-DD-MM)

Only in Preview mode they have. The static values in source view show YYYY-MM-DD for me. It may be possible in the future to change it once they add a setting for it.

Thank you, so much for your input Gino. I’ve found the same thing. Even adding new date values works as expected and keeps the underlying dates in the correct format. It’s only the display as you say. I have also noticed a similar issue in the projects plugin. The date displayed in cards on the board is also wrong, but the actual data is correct.

I came here looking for the same issue. IMO it’s a bug. if I set the display to be one thing I want it displayed that way in preview.

It’s not a bug :upside_down_face: : How date and date & time are displayed within Properties relies on your device/OS settings (on Mac you can change those in SettingsLanguage & Region. No idea how to do so on Windows/Linux though).

You might want to add your vote and/or voice to this FR :

3 Likes

I’m on Windows 10. The system has always been set to Swedish regional format with Short date yyyy-MM-dd. Obsidian date properties are nonetheless displayed as MM/dd/yyyy.

I saw several other users reporting the same issues in the various threads. So as far as I can tell, there is a bug.