Dataview - simple table won't populate

Noob here, I’ve already tried searching and posting on Reddit.

I’m trying to make a simple table with academic papers I am reading/have read. The table shows “Dataview: No results to show for table query.”.

Previously, the table would correctly populate with the files in “1. Primary Sources”, but it stopped working after renaming the source folder to “Main”.

Try force refreshing all views and blocks. Ctrl/Cmnd + P -> Dataview: Force Refresh All Views and Blocks. Other options are to close the note and open it again, or just restarting Obsidian.

1 Like

Dataview commands don’t show up in the palette. I’ve tried your other 2 suggestions without success.

Are you on a very old version of dataview? The Force Refresh command has been implemented for over a year now.
Go to Settings -> Community Plugins -> Check for updates

Also: Do other queries work?

1 Like

I believe I’m on the latest version.

I tried this and it didn’t work:

TABLE ShortSummary as "Summary", Rating
FROM "Main/2. Collections"

What about the App / Installer version of Obsidian?(Settings -> About)
Is that up-to date? If yes, i think reinstalling the plugin is your best bet.

I tested everything you did including the rename of the source folder and it works fine on my end.

1 Like

Ah of course reinstalling fixed the issue. Thank you for your help!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.