Dataview Query not returning results from a folder

What I’m trying to do

I recently moved my daily notes (which are in the format from one folder “Daily Notes” to “Daily Notes/YYYY-MM” subfolders.
Since this move, I am unable to query any information from the “Daily Notes” folder structure.
Neither LIST, TABLE nor TASK are returning any results from this.

Things I have tried

I have tried querying without having a “FROM” in the DQL. The query returns data from files in other folders in the vault but never data from the “Daily Notes”

Does the following query return anything?

LIST file.folder
WHERE startswith(file.folder, "Daily")

How did you move the files? And what do you see in the file explorer (within Obsidian or outside of it)?

This returns nothing. I set up a bash script to move the files around

If you used a bash script to move the files, then maybe Obsidian haven’t figured out that the files have moved, although it should detect. But it do seem like its cache possibly is off. Could you try editing one of the files if you haven’t, and see if that files then shows up?

Or even better, add the following to one of your “missing” files, and report back what it gives:

`= "%" + this.file.folder + "%"`

The files are showing up within Obsidian, just fine.
I was able to fetch the files using QUERY , just doesn’t seem to be working on Dataview

And what do the inline query show?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.