Dataview query ignoring month in date

Things I have tried

  • Updated Dataview, the issue remained
  • Played around with using file.ctime etc instead, but I set the date manually for when the session was played rather than the file was made so that isn’t what I want.

What I’m trying to do

I tag all my d&d notes with “date: YYYY-MM-DD”
And on a main “Journal” page I like to see all of them in tableview using dataview. My query for that table is this:

table date, tags
from "Journal"
sort date desc

However, the month is getting omitted from the table in the date column and I can’t work out why?


I’ve checked each of my session notes and they have the date configured just fine, I can’t remember this being wrong like this so I feel like it’s a new issue but I’m not 100% certain.

Any ideas?

Two questions:

  1. Show an example of your field date: to check the way you input the date (date format)
  2. In date outputs I see 22-00-10, not the default format defined by dataview (MMMM dd, yyyy). This means that you have changed the default date format in settings > dataview. Are you using the right luxon tokens? What’s your format in settings?

Hi!

The luxon settings hadn’t occurred to me at all so I went into dataview and changed it from yy-mm-dd to yyyy-MM-dd and that fixed it, thank you!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.