Dataview not showing all data

Things I have tried

Below I’ve posted screenshots of the notes I’m testing with.

The dataview block I’m having trouble with is here:

TABLE WITHOUT ID link(, default(file.aliases[0], AS "Responses", eval
WHERE contains(file.inlinks,
SORT eval desc

I’ve also tried:

TABLE WITHOUT ID link(, default(file.aliases[0], AS "Responses", eval
FROM outgoing([[]])
SORT eval desc

Which returns the same exact thing.

What I’m trying to do

The two issues I’m having are that

  1. Only one of the notes appears in the table when the two notes I’m testing with are nearly identical
  2. The eval doesn’t show up for the note that does appear

It might be worth noting that when I get rid of the FROM and SORT, the table shows all of my notes as expected

four things:

  • you don’t need link(, default(file.aliases[0], you can use only link(, file.aliases[0])
  • why you use #aliases: as a key?
  • you’re using an extra plugin to change the title of the file (I don’t know which plugin). do you test any conflict with plugins?
  • why you use all values with the “[…]”? this means all your single values are an array!

Ok I fixed that first one.

Honesty I thought the # commented out the yaml, but I could be wrong about that. I was just keeping it there for the time being until I decided for sure that I wanted to use the title instead. Btw, that plugin is called Front Matter Title. I got rid of the #aliases though since I am feeling more set on title now

I just went through and turned off each plugin one by one to test, but that didn’t fix it.

And yeah good point for the values being an array. I was just doing that out of habit since thats what I always used for my aliases since if I had one I would usually have another. That is also all fixed now so thanks for pointing that out. Sadly none that fixed the problem with dataview.

There’s something wrong with data.
Isn’t a query fault.

Try in a new vault without any other plugin (only dataview) and only with the aliases and eval fields in frontmatter.
(write new values without copy-paste)

Ohhh yup! I didn’t try in a new vault or anything, but I uninstalled dataview and reinstalled it and now it mostly works. Only thing that isn’t quite right now is that little work around to get an alias as the file link in the table. I switched it from:

TABLE WITHOUT ID link(file.alias[0], AS "Responses", eval
FROM outgoing([[]])
SORT eval desc


TABLE WITHOUT ID link(file.title, AS "Responses", eval
FROM outgoing([[]])
SORT eval desc

since I am no longer using an alias or have any of the metadata set as an array, but its just putting “-” rather than the expected link

This did the trick! Thanks for all your help!!!

TABLE WITHOUT ID link(, title) AS "Responses", eval
FROM outgoing([[]])
SORT eval desc

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.