Dataview LIST and TASK are empty, even though my vault is not empty

What I’m trying to do: Use dataview

Things I have tried





as well as any more complex queries return 0 results (“Dataview: No results to show for list query.”) even though I have pages and tasks in my vault. I do not have any special configuration for dataview.

It’s probably something very easy, but I checked the forum and the dataview help and couldn’t identify the issue so far.

As a diagnostic, if you copy and paste and match style / paste as plain text the text and queries below, do they work?

If not, check Settings > Community Plugins and make sure Dataview is active.

If it is (and presumably it must be if it is serving error messages), do you get any joy if you quit Obsidian, reboot the device, and start Obsidian again?

- [ ] This is a task

Where =

Where =

Thanks for the quick reply @anon63144152 !

Unfortunately got the same issue:

Source-code view:

I’ll try restarting my device

1 Like

If restarting doesn’t help, you could create a new test vault and only add Dataview to it. If the query still doesn’t work, there must be a wider issue with the Obsidian installation. If it does work, there must be an element in your main vault that needs some TLC.

Good luck. Sure there is a solution. What version of Obsidian and installer are in use?

If below 1.3.7, Download - Obsidian

Restart didn’t solve the issue, but indeed in a brand-new vault the queries works! Will try to debug what causes the issue in my main vault. Is there a way to see debug messages of Obsidian and the plugins?

Using Obsidian 1.3.5-1 on Manjaro/Arch Linux with a ‘normal’ system install. Will try if it works with AppImage. - are you using a community plugin for tasks like Obsidian-Tasks?

I know that if I’m querying for tasks, they won’t show up for me unless the task is tagged with #task.

1 Like

Hi @jswright91 , yep using Tasks, but I also tried disabling it as well as all other plugins and still doesn’t work in that vault.

Possible cause? I get “Uncaught (in promise) Error: Code block postprocessor for language dataview is already registered” in the debugger

@mnaoumov has a debug guide:

How to debug Obsidian Plugins - Share & showcase - Obsidian Forum


GitHub - chrisgrieser/obsidian-divide-and-conquer: An Obsidian plugin that provides commands for bulk enabling/disabling of plugins. Useful for debugging when you have many plugins.

A lot of the time, turning off all plugins and then—staring with Dataview—add them back one at a time until something stops Dataview from running.

And is Dataview in the main vault also up to date?

Afraid I know nothing of Linux, but I expect others will be able to help.

I think I found the issue. In the settings, I changed the ‘DataviewJS Keyword’ from ‘dataviewjs’ to ‘dataview’ as I thought that is needed to write ‘dataview’ code blocks. That seems to have caused my issues! Having the default ‘dataviewjs’ and it works :).

Thanks a lot for your help everyone :).


Great to hear. Thanks for sharing the solution—might help others in the future.

Hi All,

Super similar issue here, but since it’s fresh for you, I’m hoping for some help. I tried what did with ‘data views’, but that didn’t work for me.

Somer context: I’m creating a greater list of items that I own and a wishlist, organizing them into where they belong in my house.

See the screenshot below for the YAML of my desk top from Ikea:

TABLE room as "Room," organizetags as "Topic", use as "Use", price as "Price", value as "Value"
FROM #ownedItems AND "02. Resources"
WHERE room = "My Office"
SORT room asc

Do you think it has to do with the YAML type being a list? (the difference in symbols next to “room” and “brand”)

This pulls all of my Ikea products in:

TABLE room as "Room", organizetags as "Topic", use as "Use", price as "Price", value as "Value"
FROM #ownedItems AND "02. Resources"
WHERE room = "My Office" OR brand = "Ikea"
SORT room asc

Please create new posts for new issues. If the line above is a direct copy of your query you’ll need to change "Room," to "Room", to make it syntactically correct.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.