Dataview leads to problems with cursor navigation, when using embeded images

Hi guys,

I experience some strange cursor behaviour, when using dataviews and embeded images in the same note.

To show what happens, I recorded a video, see link here

What you will see:

  • with activated dataview:
    => when I want to navigate with my keyboard from line 15 to line 16, the cursor directly jumps a few lines more…

  • without activated dataview:
    => it jumps one line after another…

I read the tipps of @rigmarole in this post:

… and updated my themes.

I did not yet download the new installer, because I’m afraid, that all my settings will be overwritten… - or will my settings be kept in the .obsidian-folder and I will have the same settings after reinstalling?

Here is my debug-info:
Obsidian version: v1.1.16
Installer version: v0.15.8
Operating system: Windows 10 Pro 10.0.19044
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: LYT Mode v1.6.2
Snippets enabled: 0
Restricted mode: off
Plugins installed: 45
Plugins enabled: 29
1: Hider v1.2.4
2: Advanced Tables v0.18.1
3: Vantage - Advanced search builder v1.4.2
4: Natural Language Dates v0.6.1
5: Calendar v1.5.10
6: Excalidraw v1.8.20
7: Underline v1.2.1
8: Tag Wrangler v0.5.7
9: Outliner v4.3.0
10: Image Toolkit v1.3.1
11: Tasks v2.0.1
12: Omnisearch v1.13.0
13: Excel to Markdown Table v0.4.0
14: Keyboard Analyzer v0.1.3
15: Copy as HTML v1.0.6
16: Tracker v1.10.9
17: Annotator v0.2.10
18: Templater v1.16.0
19: Pandoc Plugin v0.4.1
20: Kanban v1.5.2
21: Dictionary v2.22.0
22: Better Word Count v0.9.4
23: Emoji Toolbar v0.4.0
24: Hotkeys++ v0.2.7
25: Hotkeys for templates v1.4.3
26: Periodic Notes v0.0.17
27: MetaEdit v1.8.0
28: Recent Files v1.3.5
29: Dataview v0.5.55

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Thanks in advance for any advises! :slight_smile:

Reinstalling is safe. Your settings are stored in your vault. Your vault will not be touched when you reinstall the app.

If you want to be extra safe, you can make a backup of your app settings in %APPDATA%\Obsidian\. But this is not necessary to do.

Hi Rigmarole,

Thank you for your reply. I have reinstalled Obsidian, but the strange behavior persists.
But as I changed my theme from “LYT Mode” to "Default, there strange cursor behaviour was gone.

With “LYT Mode” theme I experience the same issue when including tables in notes that also have dataviews.

Maybe there’s also a correlation between strange line numbers in the “LYT Mode” theme, see here:

LYT Mode theme:

Default theme:

As you can see in the attached images, the line numbers in the LYT Mode theme are not at the right place.

I’ll also point the developer to that issue.

Thanks for your advise anyways!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.