Dataview Error - Folder Within Folder

Disclaimer - I am pretty new to Obsidian and am definitely not a coder, so I’ll do my best to explain this.

Things I have tried

Renamed folders, rewritten the path in the dataview query a number of ways but nothing is working. This is the query I’m using

table Book, Location, Status, Summary
from "Lost Causes/1.Something Borrowed/SB Chapters" 

What I’m trying to do

I want a table that displays the above sourced from a folder within a folder. It works just fine if the “SB Chapters” folder is just in the vault and not within another folder. What am I missing?

Thank you!

Could you paste a screenshot of your file structure? This seems to work for me, so I’m wondering if perhaps there’s a small typo in your query. For example, if your folder is actually 1. Something Borrowed (with a space after the 1.), the above wouldn’t work.


Thanks for replying! I’m putting two examples in here that worked before I moved a folder within a folder.

Screen Shot 2023-01-28 at 10.21.46 PM

Same issue here.

Screen Shot 2023-01-28 at 10.22.08 PM

For the first one, try without the vault name in the from path (if “Lost Causes” is indeed the vault name). If the vault name is in there no results are returned. So,

table Book, Location, Status, Summary
from "1. Something Borrowed/SB Chapters"
sort asc

For the second one is “5. World Building” in the vault root along with “1. Something Borrowed”? If so, the path looks fine. Maybe check the metadata on those files in “Characters”?


Thank you! It worked. :slight_smile:


Team effort :muscle:t3:

Geoffb spotting the space and suggesting screenshots put us on the right track!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.