Data Loss without iCloud/Obsidian sync

As i was editing the file (pasting some php code), obsidian simply closed it and removed from the folder and i cannot find it anywhere not even in the thrash bin.
I don’t use iCloud sync nor obsidian sync.
My install is clean, i have safe mode on, and no custom css.
Only have 2 folders, with a combined total of 6 files.

I could retrieve the data lost via the File Recovery plugin.

Steps to reproduce

Simply pasting or writing by hand the three lines in the following pastebin [](, wait a bit and voilá, the file is missing. I've been able to reproduce several times in a row. If i change one character, it doesn't trigger the bug.

I’ve tried to replace the characters and nothing happened (haven’t tried all characteres, but at least 20 in diferent places). But after i changed them back, it triggered and the file went missing.

Expected result

Just a normal file change.

Actual result

The file is deleted without trace


  • Operating system: Windows 10 Education
  • Debug info:
    Obsidian version: v0.14.6
    Installer version: v0.13.31
    Operating system: Windows 10 Education 10.0.19042
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Safe mode: on


Additional information

I can’t reproduce.

post a screen recording of this happening in the sandbox vault.

Also see if you get any errors in console (ctrl-shift-i)

In the sandbox is the same thing

In the video i paste the code with a modified character and then change it back to the “correct” char. You can see the error popping up and then the file goes MIA. (2.9 MB)

download and reinstall obsidian form the website. does it still happen?

Do you have an antivirus installed?

I turned off Windows Security Real time protection, and you’re right. I played a while with it and confirmed it was the Windows Defender fault.
Thanks and sorry for the wasted time.

I don’t use Windows Defender, but doesn’t it let you know when it’s triggered a protective action?

Yes it does, but my home PC has notifications turned off, so i wasn’t seeing them.
I tried in another PC this morning and that’s when i saw it.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.