Data deletion BUG? Moved Obsidian Vault from Win to Mac and it deleted the imported Vault folder (also, plugins didn't transfer)

I am new-ish to Obsidian. Started using it briefly on my Win PC, stopped for a while, got a Mac and decided to resume. I did accumulate quite a few valuable notes and carefully curated a lot of plugins for myself.

Just tried to migrate.
Moved my Obsidian Vault from Win to Mac. Uploaded my Vault folder to SMB share. Chose ‘open existing folder’ on Mac and opened the folder from the network share.

Then I noticed that the Mac version did not transfer my plugins and is running in restricted mode altogether. I went to check the Vault folder to see if the plugins were in there, and the folder is missing from the SMB share.

  1. Is it normal for the new instance of a Mac version to delete the source vault upon ingesting it? I was under the impression that it’s supposed to just happily continue using that vault.

Seems like a bug?

  1. Is it normal that the settings and plugins did not transfer?
    Before I migrated I read relevant threads on Reddit, and they all mentioned that the vault folder is supposed to be fully self-sufficient and include not just documents, but also settings and plugins. And since plugins are written in JS, they should be cross-platform and not care whether it’s a Win PC or a Mac.

Is this a bug?

The notes seem to be present in the Mac version. Did it copy them to Mac local drive and delete the SMB source willy nilly?

I am afraid to use the imported notes so as to not corrupt the missing plugin’s potentially present metadata in them. I am afraid that since the plugins are missing, there is nothing to stop anything else from overwriting it.


The plot thickens: the folder reappeared on the share. Restarted Obsidian on Mac, but it still doesn’t see the plugins from that folder even though they are there.

Given that there’s a network share involved, Obsidian wouldn’t be my first guess as to what caused the disappearance and reappearance. I don’t know how well that kind of setup is supported — if you haven’t already, I recommend searching the forum for posts about similar setups. Obsidian expects its files to always be present, so if the connection to the network share is interrupted it could cause problems.

If you don’t already have a backup system setup, I strongly recommend doing so now.


It sounds like the .obsidian folder didn’t get uploaded or synced properly. Or maybe there was a delay.

Then when you opened Obsidian, if that folder was missing, Obsidian would regenerate a fresh one.

Then if your old version finally uploaded, you might have a mix of old and new settings.

I’d suggest closing Obsidian and transferring the entire .obsidian folder again from the original source. I hope you copied it and didn’t move it. Or that you made a backup.

Yeah, it wasn’t a move - I copied.

Tried copying locally into the Documents folder on Mac. Opened the vault - same thing. It’s not seeing the plugins and settings. Are Mac and Windows versions supposed to be compatible?

How specifically? Through the SMB? Maybe whatever transfer method you are using is skipping hidden folders. Maybe there is an option or flag for that.

Otherwise, maybe try zipping up the entire vault, and transfer that .zip instead. Then you’ll (hopefully) have it all, plus maintain modified and creation dates.

Obsidian? Yes. The transfer method you are using? That depends.

1 Like

Thanks to this fella from TrueNAS forums, found out why Obsidian folder doesn’t show up even though it’s there (it was not deleted) - #2 in his post:

Apparently, Finder is a piece of shit to work with SMBs. Even closing the Finder window won’t refresh the contents as one would think it should.

It’s not showing up right now. But I can access it via go to folder or Terminal though when it’s invisible.

That doesn’t solve the plugin/settings transfer issue though.
They do get copied:

And yet it keeps saying You currently have 0 plugins installed:

I can and probably will install them from scratch since I essentially have a list of what I had by looking at the plugins folder, but this mystery is annoying.

Also, despite ingesting the vault, it starts in restricted mode.
I enable community plugins (i.e., disable restricted mode), restart Obsidian, but the plugins from the vault still do not show up.

I think when you first add a vault it starts in restricted mode even if it wasn’t in that mode before. I guess this is meant as protection for people who use sample vaults from others. (If it keeps opening in restricted mode, that’s not normal.)

1 Like

It doesn’t keep opening in restricted mode, but it also still won’t absorb the plugins upon subsequent starts in UN-restricted mode.

Some weird stuff is going on with SMB on Mac:

I just saw the Obsidian folder in the SMB share.
Copied it again to Mac.
After I copied it, the Obsidian folder on SMB share became invisible again. It’s still accessible via Terminal or “Go to” in Finder. Just invisible.

Wouldn’t call Apple’s SMB implementation even an intern-worthy level of craftsmanship. SO BAD.

I figured out why the plugins weren’t being visible.
My Obsidian folder structure (top to down):

Foo-notes (name of my vault)
2 folders: Foo-notes (again) and image
Inside Foo-notes:
My notes and the .Obsidian folder:

After I moved .Obsidian folder one level up, it started seeing all the plugins and instantly absorbed my settings too.

Looks like there is a discrepancy where my Windows version of Obsidian from mid 2023 and my current version of Obsidian for Mac from 2024 place this folder (and, subsequently, where they look for it).

Also, not sure why there are 2 nested Foo-notes folders, and what the image folder is for (images from my notes are stored elsewhere).

Are you using nested vaults or something?

I am beginning to suspect that when you do “Open existing folder” — Which should actually be “Open folder as vault” if your UI is set to English — you are perhaps choosing the wrong folder, causing Obsidian to generate fresh .obsidian settings.

You said “My Obsidian folder structure” and then you listed “Obsidian” and “Vaults”. Those are not part of your Obsidian folder structure. If your vault is “Foo-notes”, then your vault IS and BEGINS AT “Foo-notes”. The folders above are completely irrelevant. (Or they should be, if we cancel out any weird SMB problems.)

When you choose “Open folder as vault” you should be choosing “Foo-notes”. Is that what you were doing? Is .obsidian underneath “Foo-notes” on your original computer before transferring via SMB?

That’s not the case. The .obsidian folder is always in the root of your vault. If it’s being moved, it’s through the way you are moving files, or through your file system tools or network tools.

1 Like

I just want to add one point, as a general guideline. It’s probably best not to use generic names that match the name of an app or a concept in that app. So naming a folder “Obsidian” or “Vault” can be confusing. Especially if you don’t access the app for a long time.

It would be better to give it a unique descriptive name.


Thank you, Mr. Mouse.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.