Daily notes of inner vault erased and overridden

Steps to reproduce

  1. Create new vault (“inner vault”) under folder (“outer vault”).
  2. Create daily note in the inner vault and create new folder path for daily note.
  3. Write in some paragraphs and text for this daily note.
  4. Switch back to outer vault.
  5. Clicked on the new folder (created in inner vault) and clicked on the daily note.
  6. Opened today’s note with the hotkeys i used.
  7. Somehow the daily note for my outer vault (which is empty) overrode the daily note for my inner vault (which had text), and now the latter is empty.

Expected result

  1. Daily notes for outer vault with no text, as I had not written anything yet.
  2. Daily note for inner vault with the text I wrote in.

Actual result

  1. Daily notes i wrote for inner text is all gone!


  • Operating system: Windows 10
  • Obsidian version: v0.73
  • Using custom CSS: Obsidian Boom

Additional information

Thanks for the chat on discord.

probably the outvault tried to recreate the same file that was open in the inner vault and ended up destroying it.

@Licat we need to explicitly forbit users to create nested vaults. Aside from this issue, this will break the internal linking sforbid

I can’t seem to repro: (WIndows 10 as well, 0.7.3)

Steps 1-3:

Step 4-5:

Here after this, I switch to another document just in case. I tried without switching either.
Step 6-7: (Notice how cursor focused on the note)

When you click the daily note button (or trigger via hotkey) in the “outer vault” it should open the note created in the other vault, unless you have the format set to a different date format.

So I’m not seeing a new file being created (but it seems like you are seeing a new empty file). Where is it being created at?

Hi, thanks for helping out!

When I triggered the hotkey in the outer vault, you’re right, it did open the daily note in the nested vault, however, i was entering 1-2 letters before the text got all erased. so i ctrl-z in hopes of undoing it, but it was still a blank page.

after this happened, i have since moved this nested vault out into my desktop (daily notes still empty) so it’s not within my existing vault, and unfortunately i can’t repro the bug as well :frowning:

maybe i missed a step somewhere?

OK, i am going to archive this. Let use know you have problems again.

1 Like

Oh interesting. Just a quick follow-up, do you happen to have some kind of synchronization software running off that folder?

No I don’t - not that I’m aware of…!

@WhiteNoise See the discussion in this thread–there’s a suggested workflow under which having nested vaults would actually be really nice. Obsidian promises that “it’s all plain text”, which seems to encourage such workflows, so I’d suggest that the better approach is for Obsidian to explicitly test for this use case.