Daily notes format not saving

Steps to reproduce

It is not saving my daily notes format:

/yyyy/MMM/[Week] ww/dddd (DD)

I change it in settings, don’t write a note for a few days, and then when I go to write a new daily note it no longer uses the right format.

Did you follow the troubleshooting guide? [Y/N] I did, but as this bug is inconsistent and takes a bit of time I was unable to recreate it in sandbox.

Expected result

It should save the format

Actual result

It does not.


Obsidian version: v1.5.12
Installer version: v1.4.16
Operating system: Darwin Kernel Version 23.2.0: Wed Nov 15 21:53:34 PST 2023; root:xnu-10002.61.3~2/RELEASE_ARM64_T8103 23.2.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 2
Plugins enabled: 2
1: Paste URL into selection v1.7.0
2: Calendar v1.5.10

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

Where is your vault on disk? Is it a sync folder like iCloud Drive or something like that?

Settings randomly reverting is sometimes caused by an older version of the settings file being downloaded and/or the settings file itself being removed, so Obsidian creates a new one with the default settings.

The Daily notes settings you’ve changed are saved in {VAULT-NAME}/.obsidian/daily-notes.json.

Something to investigate.

It is on iCloud Drive, the sync sucks with mobile though, like it’s really bad, should I just move the whole thing local and see if that solves it?

That cloud icon to the right of the folder there is bad. It means not all of the files in that folder are downloaded locally to disk. You could try right clicking on folders with that icon and Download now (or something similar).

iCloud Drive is generally alright on macOS devices, in my experience, but you’ll want to make sure System Settings > Apple ID > iCloud -> Optimize Mac Storage is disabled. That can cause issues if it’s enabled, like files being randomly removed from your device.

Unfortunately I have the base level M1 mac so I can’t turn that off, I have a very difficult time managing storage on this thing.