Custom URL links are not clickable in edit mode

Steps to reproduce

Add a custom URL link that works when clicked in other programs or put into a browser. For me, it’s a link like zotero://select/library/items/3AKXT9F7

Expected result

The link shows as clickable and is opened when Ctrl+clicked in edit mode

Actual result

Link acts as plain text


  • Operating system: Win 10 x64
  • Obsidian version: 0.9.10

Additional information

I can’t reproduce this. As I mentioned in Request - working custom URL schemes in edit view, this seems to me like an issue with your setup. If your browser is not able to open the zotero:// link, Obsidian won’t be able to either.

Have you tried putting the zotero://select/… link into angle brackets, i.e.

i.e. <zotero://select/library/items/3AKXT9F7> ?

I’m on macOS but have functional links from Obsidian to my local Zotero with this.

As stated here and in the previous thread, the link does work when put into a browser. The browser is able to open the zotero link.

My bad! Totally misread that. A couple of things that we need to know:

  • Could you please add a GIF of the link working in the browser and not working in Obsidian?
  • Do links work in either preview or edit mode? (i.e. have you tried both and are using the right key combinations?)
  • What installer version do you have?

One other thing that would be good to know, do you have custom URIs in your notes to any other app, e.g. todoist, evernote, or something like this that does work?

Is the link properly formatted, i.e. [my zotero link](zotero://....)?

Not a bug. you need to use [Text](zotero://url).

This works fine in my setup:


My expectation was that custom URLs should look and act just like normal http:// links. My normal links have different formatting and can be ctrl+clicked without linking text in brackets. My zotero links cannot.

If custom URLs are supposed to look/act the same as normal links, then this seems to be a bug. If not, is this intended difference documented somewhere? It confused me.

1 Like

http is more an exception than the rule. Given how common it is.
In markdown, you use [](). That’s in the docs.

1 Like

I do feel that choosing wikilinks instead of markdown links should allow simpler link syntax throughout.