Custom CSS in Obsidian Publish isn't Working

Hello Everyone,

I created a new file (publish.css) and added it to my vault directory. But nothing seems to happen after publishing. The same look and feel without the CSS changes in publish.css

I’ve tried to clear cache memory and use different browsers from different operating systems. And the problem is still the same.publish.css (7.6 KB)

CSS file: attached
Published website:

Anyone can help?

Thank you in advance.

Hello, Tarek.

I don’t have Obsidian Publish, so I am really not the right person to reply here, but as no one else has so far, I thought I would try to help.

Using the developer tools in Safari, the only CSS file I can find being referenced is the default one provided by Obsidian.

Is the publish.css file you created in the root of your vault? See this thread / post by the developer.

Hope someone can give you better advice.


1 Like

Thank you very much Angel, I misunderstood the word “root” & “vault”. I thought it should be inside of the published folder. Because I have more than a folder in the same vault, but I published only one.

Thank you again for your help :slight_smile:
I really appreciate it.

A great pleasure, Tarek.

I looked at the site: beautiful.


1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.