Custom app icon not showing in Ubuntu gnome when image size is too large

Steps to reproduce

  1. Use vanilla (gnome) Ubuntu 23.04
  2. Run Obsidian AppImage 1.3.5. Insider version is 1.3.7 and installer version is 1.3.5
  3. Set a custom app icon Settings > Appearance > Custom app icon
  4. Restart obsidian
  5. Open sandbox vault, double check that the custom app icon is still set in the sandbox vault
  6. Custom icon does not show on the gnome application bar in Ubuntu.

Did you follow the troubleshooting guide? Yes

  • No plugins, no custom css, no themes
  • Sandbox vault
  • Using AppImage

Expected result

To see an Obsidian instance in my Ubuntu-gnome application bar with the custom app icon I selected

Actual result

The old Obsidian icon shows in my application bar.


	Obsidian version: v1.3.7
	Installer version: v1.3.5
	Operating system: #23-Ubuntu SMP PREEMPT_DYNAMIC Wed May 17 16:55:20 UTC 2023 6.2.0-23-generic
	Login status: logged in
	Catalyst license: insider
	Insider build toggle: on
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on


Additional information

The old obsidian icon can be seen in the application bar on the left. Custom app icon is set as can be seen in the screenshot

The issue had to do with that my app icon’s resolution was too big for Gnome/electron to handle. The Mac OS icon of about 1800x1800’s resolution is too large. Around 500x500 does work!

Perhaps a small warning could be shown if the icon resolution is too large?

Otherwise, a static text with “Make sure your icon size is accepted by your OS/desktop environment, otherwise it might not show correctly” or something along those lines could be nice.

thanks. We are not going to handle hedge cases involving this not working. This functionality is mostly handled by electron is OS dependent.