Cursor won't allow me to edit

Steps to reproduce

Open and page/ note. The cursor is bold and doesn’t allow me to edit. It keeps jumping

Expected result

Easily edit a note.
See the thin cursor. (Flashing line to edit)

Actual result

Unable to edit until I hit multiple keys on the keyboard. The cursor jumps. Deletes random words. Then the thin editable cursor is visible. I need to then undo(ctrl+Z) everything and restore the note.
I can then edit.

Environment

  • Operating system: WIndows 10 Home 64-bit (10.0, Build 19042)
  • Obsidian version: v0.11.5

Additional information

Here is the screencast.
https://drive.google.com/file/d/1Vpb-n5JyIHE83SKXPFNo1r0eRHaSnEVx/view?usp=sharing

I have uninstalled and reinstalled the latest version of obsidian. It still doesn’t seem to work. This has been going on for over a month.

1 Like

I have seen this only in the last few days. I’m dead in the water now. I cannot edit any of my notes. I cannot even create text in a newly created note. I wonder what happened. I have checked for updates and am operating on the latest version, according to the Obsidian update checker. (0.11.5)

you enbled VIM mode without understanding what you were doing. Go in the editor settings and disable it. Also, in the future, please don’t submit bug reports with third partyplugins or css enabled.

Jeeez, just a little bit hostile there, no? In any case, I do NOT have VIM bindings set. I just went to the editor and checked.

The problem “magically” vanished. It works correctly with third party plugins disabled or enabled. As I remember, the very first thing I did, after checking for updates to be assured that I was on the latest level, was to disable community plugins. As to the VIM key bindings you say I set, I can’t speak to that. This was my first attempt to learn and use this product so it is entirely possible that I accidently set that feature. I am not a VIM user so I would not have intentionally set it. So … It is entirely possible that I deleted Obsidian entirely and reinstalled it … which could account for the “magic”. I don’t remember doing that but it is a normal part of my troubleshooting practice.

I’ll just mention it here, though it is a different issue, that the ALT + SHFT + - highlight does not toggle, but keeps adding highlight. A search in “hotkeys” shows that I am using the correct hot key. Changing the hotkey to CTL + SHFT + - does not alter the behavior. Nor does changing it back to the original hotkey. NOTE: This is with all community plugins OFF.

I replied to the problem report of another user wherein you said it would be fixed in V0.7.7, IIRC.