Cursor Positioning and Editing Bug with Checkboxes Post-Update 1.5.8

Steps to reproduce:

  1. Update Obsidian to version 1.5.8 on a Windows 11 PC.
  2. Ensure no third-party plugins are used.
  3. Edit a note containing lines with checkboxes (formatted as “- ”).
  4. Navigate through the text using the up or down arrow keys and attempt to select, delete, cut, or paste lines with checkboxes.

Did you follow the troubleshooting guide? [Y/N]: Yes

Expected result: The cursor maintains its initial position at the start of the line when navigating through or editing text. Editing operations involving lines with checkboxes should proceed without the need for manual cursor repositioning.

Actual result: The cursor automatically positions itself after the checkbox when navigating through or editing lines with checkboxes. This behavior complicates editing tasks by necessitating manual cursor adjustments for deletions, selections, and cut/paste operations.

Environment: SYSTEM INFO:

  • Obsidian version: v1.5.8
  • Installer version: Previous version before update
  • Operating system: Windows 11
  • Login status: Not logged in
  • Insider build toggle: Off
  • Live preview: On
  • Base theme: Adapt to system
  • Community theme: None
  • Snippets enabled: 0
  • Restricted mode: Off
  • Plugins installed: 0
  • Plugins enabled: 0


I don’t understand what the problem is. Can you post a screen recording of this problem in the sandbox vault?

@jaw1 also had a discussion about this matter before logging the bug report, I added some additional information here to that.

It’s a little hard to quantify the variance in behaviour, but hopefully I’ve documented okay. I suspect there were a few behaviours that changed around this, but I can’t seem to work out what they are as I use Obsidian with muscle memory and struggle to work out what’s changed.

One obvious one is as @jaw1 has documented. Here’s videos of both 1.5.3 and 1.5.8 in the sandbox vault, with comments on the difference:

Additional information, looking through the changelog I suspect this from 1.5.8 to be the likely cause:

Improvements for indented text and lists in Live Preview.

It’s worth noting (mention in the other linked thread) that this only does occur in Live Preview mode.

I can’t reproduce in 1.5.11


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.