"Cursor Highlight" won't work

I’m sorry I’ve tried to search for this, but I’m not a native speaker and I might be using the wrong search terms.

Usually, if you select text with your cursor, the text will be highlighted.
It’s not a real highlight, because if you click somewhere else, the highlight will disappear again.

If I select text, it will not be highlighted (this only happens in Obsidian, all other programs work fine).

This error suddenly appeared (I did not change anything as far as I’m aware).
It appears, although I’m on the newest version (macOS, Obsidian, templates, plugins) and persists, even if I change templates or switch off all plugins.

I’m completely at a loss of what else to try or what to search for.
Does anybody have a suggestion of where I could look for the reason?
Links, ideas, code, anything …

Thanks in advance!

Posting in this forum helped.
I’m dead serious.
After I posted this question-post, I created a new note, to save the link for further reference (so that I could come back and check for answers).
In this new note, I could see the highlight, when I tried to change the heading in something more meaningful.
Further testing showed that suddenly the cursor highlight worked in all the other notes, too. (where it previously didn’t work, I tested right before posting the question-post).
What happened here?
(What can I do if this error reappears???)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.