Ctrl+L default hotkey for Toggle checkbox status in 0.16 and higher doesn’t work with non-English keyboard layout

Steps to reproduce

  1. Open Obsidian 0.16 or higher
  2. Make sure you have the default hotkey set for Toggle checkbox status — Ctrl+L
  3. Change your input language to Russian or Ukrainian
  4. Press Ctrl+L

Expected result

'- [ ] ’ should be inserted

Actual result

Nothing gets typed


  • Debug info:
    Obsidian version: v0.16.2
    Installer version: v0.15.9
    Operating system: Windows 10 Pro 10.0.19044
    Login status: logged in
    Catalyst license: supporter
    Insider build toggle: on
    Live preview: off
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 5
    Restricted mode: off
    Plugins installed: 15
    Plugins enabled: 13
    1: Advanced Tables v0.17.2
    2: Recent Files v1.3.1
    3: Smart Random Note v0.2.1
    4: Tag Wrangler v0.4.7
    5: Zoom v0.2.8
    6: Dynamic Table of Contents v0.0.23
    7: Cycle through Panes v0.0.12
    8: Paste URL into selection v1.6.0
    9: Note Refactor v1.7.1
    10: Find unlinked files and unresolved links v1.3.1
    11: Auto Link Title v1.2.5
    12: Smarter Markdown Hotkeys v1.3.2
    13: Outliner v2.0.8

Additional information

If you switch your keyboard layout / input language to English, the hotkey works.
Hotkeys Alt+L, Ctrl+Alt+L, etc. work fine.

Still not clear why only one specific default hotkey misbehaves like that. Why standard hotkeys like Ctrl+P/N/K/O etc. work in any layout from the box, and Ctrl+L does not?

because probably P/N/K/O are in the same spot (more technically produce the same keycode) in all keyboard layout.

Well, assumptions can be made, and I can check tables of symbolic constants, hex codes, virtual keys, scan codes… But a guess is not solid enough, and mine is no better than yours. Since this is the only key I found so far that does not work from the box, the bug report is still relevant, if you ask me, unless a dev replies.

I’m curious, have you tried removing the default mapping then adding it back manually?

That is, have you tried removing the default and adding Ctrl+Л ?

@pmbauer, I don’t need Ctrl+Л :slight_smile: I need Ctrl+L to work. The ‘L’ key has a Cyrillic ‘Д’ letter on it, not ‘Л’.
If I go to Hotkeys, remove the default Ctrl+L and replace it with the same combination (Ctrl+L) — it starts to work, whatever input language I use, English or non-English.
So the problem is that it does not work from the box and I have to remap it, using the exact same hotkey, while other default hotkeys just work.

Well you have a pretty ridiculously easy fix then. No need to be so rude to everyone. And whitenoise is right about the codes.