Ctrl + I short cut does something unexpected when no short-cut is assigned

Steps to reproduce

  1. Open Help → Sandbox vault → Open
  2. Setting → Hotkeys → Toggle Italics → (Remove Ctrl + I hotkey)
  3. Go to any editor/file
  4. Type Ctrl + I

Did you follow the troubleshooting guide? [Y/N] Y

Expected result

No change in the editor.

Actual result

Typing Ctrl + I selects full content in the editor as if I type Ctrl + A.
I understand ctrl + A (selecting all text) is by the system (or chrome/electron), but don’t understand what is triggering the behavior when I type Ctrl + I .

It prevents to use ‘Ctrl + I’ as a leader key with leader hotkeys extension (GitHub - tgrosinger/leader-hotkeys-obsidian: Use a leader-key (tmux style) for hotkeys in Obsidian.md)


Tested on Ubuntu 22.04 with AppImage

Obsidian version: v1.4.14
Installer version: v1.4.11
Operating system: #32~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Fri Aug 18 10:40:13 UTC 2 6.2.0-32-generic
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

I have the same problem!
For me, CTRL + I is italic, but it’s lead to ctrl+A.

yes this comes from codemirror. I wonder if we should remove it or not. We’ll think about it.

1 Like