Ctrl-D no longer scrolls in Vim Mode after 0.7.6 update

Info

Ctrl-D no longer functions as expected in Vim normal mode. This is a very basic movement key in Vim that I use all of the time, so this has really disrupted my workflow.

Steps to reproduce

  1. Enable Vim key bindings in settings
  2. Press Ctrl-D in normal mode

Expected result

Scroll half a page down.

Actual result

Deletes a paragraph.

Environment

  • Operating system: Windows 10 Pro for Workstations
  • Obsidian version: 0.7.6

3 Likes

The 0.7.6 added a new keyboard shortcut for the Ctrl+D that deletes the paragraph.
Just remap it!

That was the first thing I tried. I unmapped it and it didn’t do anything at all in normal mode after that. It would be nice if the mappings only applied to insert mode or if that was an option to only apply them to insert mode.

2 Likes

+1

I was about to post this as well but saw it was already being reported by @kevineato, also tried to remap Ctrl + D like @piotry said but it still didn’t work. I’m using Windows 10 with Obsidian v0.7.6.

Verified not working. Using Ubuntu 18.04 with Vim key bindings and Ctrl + D not bound to a hotkey.

1 Like

Will be fixed in 0.8.2, thanks for reporting!

Was this ever fixed? I just tried it on Linux on a RedHat 8 system and tried to go down a page. In command mode cntrl-f brings up a search box at the bottom, ctrl-d deletes the paragraph I’m on. Thats TERRIBLE.

Strangely enough, on my Mac with Obsidian this behavior is not there. Both are running 0.14.5