Creating tables with | no longer works

What I’m trying to do

Create a table.

Things I have tried

Using “insert table” works as expected, but the old method of using | column 1 | columns 2 | does not.

Is this the expected behavior? the insert table command is fine as it is, but it’s not as fast as just using the pipe commands.

Any ideas?

It depends on what you mean by “no longer works” - no longer works in what sense? Does Obsidian not allow you to type the | character?

Because it works just fine on my end, it’s just that as soon as you start creating the |---| separator it will convert to an editable live table in live preview mode.

P.S. If you want to get the live table editing feature, you must also type the first |---| separator line after the header line to tell Obsidian that you want a table, it’s not enough to just type the header line :wink:

1 Like

Also, make sure you have a blank line before your table, which is now required but I believe was not required in the past.

2 Likes

Thank you both. I was typing the |---| but it wasn’t working, and the problem, as @egauthier pointed out, was that I didn’t have a blank line before the table.

Now, the next annoyance is that pressing enter on the last column doesn’t take me to the left-most column of the next row!

1 Like
  • Use Tab to go to the first column of the next (or new) row.
  • Use Enter to go to the same column in the next (or new) row.
  • Use Shift + Enter to create a new line in the current cell.

Personally, I find the current system very intuitive and elegant.

1 Like

I’m adding this note in as another potential solution for users searching for answers discovering this thread like I was. In my case, I had a plugin called Smart Typography that had a setting for Dashes to replace two-dashes to an En-Dash that was turned on. It was driving me crazy trying to find an answer. All the searches suggesting Mac keyboard settings, etc., weren’t working for me. I could cut and paste sample code of table examples and they’d work fine, but I couldn’t type them directly. I finally turned off all community plugins and the problem went away. Through trial and error I found the problem. Once I found this plug in option and turned it off, my problems typing dashes went away and I could create tables in markdown again.

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.