Copying gives weird characters

Things I have tried

The forum gives me no solution. I tried different chrome extentions.

What I’m trying to do

Since last version (now I am using v0.15.9 I get weird characters

  1. at the chrome extension “Copy as Markdown” (Copy as Markdown - Chrome Web Store) I often copy an address and lately it gives me these strange characters. I approached the author of the extension and this was not an extension-related problem.
  2. also within Obsidian, when I copy a section that contains a hyperlink then those weird characters appear when pasting. Hence I think it is an Obsidian related problem.
    I’ll take the address of Obsidian as an example. When I copy this address into the address bar (google chrome) with ‘Copy as Markdown’, (and when I select a hyperlinked section within obsidian) it should give the following:

Obsidian
What do I get now:

So in order to make it readable in obsidian, I need to use the

[](>* and the >) always removed.

What can I do to solve this.

Translated with DeepL

If you “Paste as plain text” in Obsidian (add Shift to your keyboard shortcut for paste, or right-click and it should be an option if you paste with mouse/finger/pointing-device) does the behavior change at all?

No it is still copied as [](>*Obsidian

with the >) after ( apparantly it does not shows)

Do you get the same behavior if you disable all community plugins and theme? (Or in a fresh vault with no plugins/theme/snippets added?)

I do not see the point of disabeling all plugins while the plugins did not affect this in previous versions.

Anyway I have now unchecked all community plugins on your recommendation and the copy no longer gives weird characters, only it is now preceded by a bullet.

1 Like

Well that is surprising! It is possible that some plugin recently added functionality that is confusing things. Good luck on your further investigations!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.