Copying by hotkey doesn't work when Vim plugin enabled

Copy doesn’t work when using the keyboard shortcuts. In both Insert and Normal mode.
Right clicking and then selecting Copy does work.

1 Like

Copying should work.

What OS are you on? What version of Obsidian?

If you temporarily disable Vim Mode plugin, does Copy using the shortcut work? (This shouldn’t matter. Just testing.)

I am fairly sure that Copy and Paste are not Obsidian shortcuts, but are handled by your OS. So there is also a chance you have an app or service or hotkey manager installed that might be interfering with that shortcut.

I’m on Ubuntu 20.04 and version 0.8.8

Without the Vim keybindings enabled Copy works as it should.

If it would be handled by the OS I would experience problems in other applications as well, which I don’t.

I moved this into a separate bug report.

Summary: The Copy hotkey Ctrl-C does not seem to work in Ubuntu, when the Vim Mode plugin is loaded. It doesn’t work in either Insert or Normal Modes.

3 Likes

2 posts were merged into an existing topic: VIM Mode - Quality of Life Improvements

This is a problem in CodeMirror, see [vim] Ability to perform a copy · Issue #3075 · codemirror/CodeMirror · GitHub

It affects other applications built on CodeMirror too, for example Enable Ctrl+C copy selection while in vim-mode · Issue #688 · LightTable/LightTable · GitHub

Based on the LightTable report, it seems like it should be fixable and/or workaroundable in Obsidian