Copy pasting image file results in Quick Look (?) image

Steps to reproduce

  1. Be on macOS (haven’t tested this on other OS’es)
  2. Have a png or jpeg file (haven’t tested other formats)
  3. In Finder select the file and Copy
  4. In Obsidian, when in a note, paste the image

Expected result

I expect the actual image to be added to the vault and the image embedded in the note.

Actual result

I get this image added to my vault and embedded.


	Obsidian version: v1.2.8
	Installer version: v1.0.0
	Operating system: Darwin Kernel Version 22.4.0: Mon Mar  6 21:00:17 PST 2023; root:xnu-8796.101.5~3/RELEASE_X86_64 22.4.0
	Login status: logged in
	Catalyst license: none
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: light
	Community theme: Catppuccin v0.4.5
	Snippets enabled: 0
	Restricted mode: off
	Plugins installed: 13
	Plugins enabled: 11
		1: Hotkeys++ v0.2.7
		2: Omnisearch v1.11.0
		3: Obsidian42 - BRAT v0.6.36
		4: Query Control v0.5.0
		5: Dataview v0.5.55
		6: Tasks v1.22.0
		7: Text Extractor v0.4.4
		8: Tag Wrangler v0.5.6
		9: Code Editor Shortcuts v1.12.0
		10: Templater v1.16.0
		11: Note Refactor v1.7.1

	Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

When I use my screenshot tool (Cleanshot) I can just paste from there and then I do get the actual image.

Drag and drop works as normal.

Copy and paste from an image displayed in the browser works as normal.

I tested this with my screenshot tool closed (actually closed).

I also tested this with my clipboard history tool (Jumpcut) closed.

When I read the docs I feel like this should just work.

Looks alright here.

Try restricted mode, restart, and use the default theme?

If still doesn’t work in restricted mode, the Sandbox, etc, I’d try in a different macOS user account without Jumpcut or Cleanshot installed.

Can’t repro. post a screen recording of this happening in the sandbox vault.