Copy paste

So, this may not be a problem in Obsidian itself (and it also may be a feature and not a problem). But I tend to copy-paste to Obsidian from other apps pretty often, and while I’d like this copy-paste to be “literal” (e.g., paste exactly what I copy, just as a text), currently it behaves as if it was trying to convert things to markdown from other formats.
Maybe it’s easier to explain with a screenshot. I was copy-pasting from Bibdesk, and here is what showed up in Obsidian. The [ characters became [ (as if to escape in .md code), etc.

Does anyone know a way to turn this off? I’m using Mac OS Big Sur, so may also be a system setting? But couldn’t find it. I think (but am not positive) that this only came up relatively recently; I have no recollection of this problem from last year.

I’m seeing this on Windows 10, too. Pretty sure it started somewhere between 0.10.1 and 0.10.6 (I just use the public releases, so I can’t comment on exactly which version). I’ve noticed it when copying from MS Office apps (Word, Outlook); not sure if it happens with other apps. Incredibly annoying.

Yes, it is a new feature.
I would suggest to read all the release notes

Thank you, I will. (But since I’m slow and lazy :slight_smile: is there any way to turn it off?)

yeah, it’s described in the release notes!

1 Like

OK, so just in case anyone else is wondering too and doesn’t have time to wade through the release notes…

Cmd+Shift+V pastes it in plain text (or the corresponding Ctr+Shift+V).

1 Like

Thank you. Good to know!