Context Menu under cursor moves cursor position up a line

Steps to reproduce

  • Set the show context menu under cursor hotkey
  • Press the hotkey on a word
  • The cursor will move up a line and open the context menu there

Expected result

  • I expect the context menu to shop up AT the cursor.

Actual result

CleanShot 2022-05-26 at 13.20.33


  • Operating system:
  • Debug info:
	Obsidian version: v0.14.6
	Installer version: v0.14.6
	Operating system: Darwin Kernel Version 21.5.0: Tue Apr 26 21:08:37 PDT 2022; root:xnu-8020.121.3~4/RELEASE_ARM64_T6000 21.5.0
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: Primary
	Snippets enabled: 1
	Safe mode: off
	Plugins installed: 12
	Plugins enabled: 11
		1: Obsidian Git
		2: Style Settings
		3: Hover Editor
		4: Dataview
		5: Calendar
		6: Templater
		7: Advanced Tables
		8: Code Editor Shortcuts
		9: Map View
		10: Sliding Panes (Andy's Mode)
		11: Advanced Cursors

Additional information

  • At some point the show context menu under cursor hotkey has begun moving the cursor up a line prior to showing the right click context menu. I have no idea what triggered this change since it was working a few days ago.
  • I have not changed my plugins since then.
  • I have tried uninstalling and re-installing Obsidian, no change.
  • I have tried turning safe mode back on.
  • I have tried a brand new vault.

None of the above options make the context menu behaviour return to normal.

If you search the forum for “context menu”, what do you find?

I had tried restarting my Mac which didn’t solve the problem. However, I kept the “re-open apps” setting since usually that’s useful.

I decided to also quit all the other apps on my Mac and the issue seems to have been resolved. I have no idea what was causing this problem, but at least it doesn’t seem to be an Obsidian one.

I guess that can be closed!