Content randomly disappear when exporting as PDF

Sometimes plain text disappears when I try to export file as PDF. I don’t know how to reproduce this bug, it occurs occasionally.

Reading mode in Obsidian is like:

PDF exported is like:

When I add some styles to the text, e.g. bold, highlight and math, the whole paragraph appears in the exported PDF.

Source mode:


But when I tried to process another file, this bug didn’t occur.

I’ve disabled all plugins and enabled restricted mode but the bug still occurs.

I cloud synced the obsidian vault, and the bug still occurs on another computer.

I copied the vault to an offline computer with Obsidian v0.15.9, and then the file is exported correctly.

The file I try to export is attached below.
上周工作总结.md (4.1 KB)

I can’t reproduce. If you can provide an example of this happening in the sandbox vault in the latest stable version of obsidian, we’ll look into it.

I’ve tried to disable/enable plugins one by one. The plugin Contextual Typography seems to be the cause of this bug.

And Obsidian must be relaunched after disabling the plugin, or the bug still occurs.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.