Community plugins failed to load

Things I have tried

What I’m trying to do

I have obsidian running on two different Macbooks. On one community plugins load fine (pre M1), on the other (M1) community plugins fail to load.

I have:

-uninstalled and reinstalled
-toggled the Restricted Mode option many times

I am running Obsidian
Version 1.0.0 (Installer 1.0.0).

Any help would thoroughly appreciated.

What do you mean failed to load? Do you see an error? Can you screenshot or paste the error?

Did you make sure to update all your plugins? (And your themes.)

Run the command “Show debug info” and paste the results here. The command will also show a list of recommended things to try.

I don’t have any community plugins as I have always had this error. I am not sure which other plugins I would update?

Where would I run the “Show debug info” command?

Thanks!

In Obsidian. Ctrl-P for the command palette.

Are you running a firewall, or anything like that?

It was a user error. Didn’t realize it was not approved for the firewall. Thanks!

1 Like

Sorry if this is sounding ignorant.
Can you help me with the resolution?
I am running Obsidian on macbook air m1 (personal laptop) and not sure if it is blocked in the background or firewall or something.

1 Like

please help me how did you solved this problem?

I have the same issues as you. No detectable error messages from the console ctri + shift + I and Show Debug Info.

system info: Ubuntu 22.04

Please post your “Show debug info”. It’s not errors. It’s info so we can help you.

Depending where you are in the world, it might be a DNS error related to your ISP. Details here: Not connecting to internet and Mac : Failed to load Community Plugin - #11 by ariehen

1 Like

Thanks for your reply.

  • Show Debug Info output:
SYSTEM INFO:
	Obsidian version: v1.1.9
	Installer version: v1.1.9
	Operating system: #59-Ubuntu SMP Mon Oct 17 18:53:30 UTC 2022 5.15.0-53-generic
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: off
	Plugins installed: 0
	Plugins enabled: 0

RECOMMENDATIONS:
	none
  • console output:

I expect there are some valuable error messages in the console, but no lucky.

After changing the DNS to google DNS, the issue fixed.